Мой сайт
Форма входа
Поиск
Мини-чат
Статистика
Понедельник, 18.01.2021, 05:10
Приветствую Вас Гость | RSS
Главная | Регистрация | Вход
Универсальный прибор - Страница 2 - Форум
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]

Форум » Измерительная техника » Универсальный измерительный прибор » Универсальный прибор (скриншот осциллографа)
Универсальный прибор
bliznecvyДата: Среда, 20.04.2011, 01:38 | Сообщение # 16
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
Андрей, спасибо за информацию. Выслал на radiodom2010@mail.ru свой матариал, не судите строго. На днях буду собирать железо. О результатах напишу.
 
BorДата: Четверг, 21.04.2011, 22:33 | Сообщение # 17
Рядовой
Группа: Пользователи
Сообщений: 2
Награды: 0
Репутация: 0
Статус: Offline
На печатке ошибка. 1вывод индикатора соединяется с 5 выводом(массой),а не с 6.
 
bliznecvyДата: Пятница, 22.04.2011, 22:54 | Сообщение # 18
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
Bor, большое спасибо. Собрал прибор, сидел час над ним, не работает.Ничего в голову не пришло и глаза устали. Чувствую мой косяк, а где в упор не вижу. Захожу на сайт и тут Ваша подсказка. Исправил, все пошло! Еще раз спасибо. Теперь о главном. Прибор классный и думаю полезный! Вопросы к Уважаемому автору: Откалибровал С и R, С измеряет точно, R до 100к точность приличная, а 500к показывает 800к может это неточность калибровки? И еще, без R2 и с R2 косо стартует (раличные символы в верхней строке). Если после включения коснуться R2 на 1ю ногу (RESET) прекрасно начинает работать. Anrew просветите, можно в личку.
 
AndrewДата: Пятница, 22.04.2011, 23:19 | Сообщение # 19
Генералиссимус
Группа: Администраторы
Сообщений: 6746
Награды: 16
Репутация: 75
Статус: Offline
Прибор и 100Мом точно показывает. Возможно у вас или резистор неправильный или еще какой касяк...
На больших сопротивлениях может влиять входной стабилитрон, попробуйте его отсоединить и проверить.
Вообще его нужно подбирать они разные по обратному сопротивлению...
Значит R2 ставте.
 
bliznecvyДата: Пятница, 22.04.2011, 23:37 | Сообщение # 20
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
Andrew, испавленый файл печати отправил на сайт.

Добавлено (22.04.2011, 23:37)
---------------------------------------------
С R2 не стартует, без него тоже. При касании R2 после включения заставка (Универсальный прибор АВО 2006) снимаю R2 выходит в работу. На счет входного стабилитрона актуально, попробую. Спасибо.

 
AndrewДата: Пятница, 22.04.2011, 23:38 | Сообщение # 21
Генералиссимус
Группа: Администраторы
Сообщений: 6746
Награды: 16
Репутация: 75
Статус: Offline
Вы фото платы отправили, кому полезно? Вы фьюсы правильно запрограммировали? Если у вас так, как вы говорите попробуйте конденсатор поставить с RESET на землю, резистор остается.
 
bliznecvyДата: Суббота, 23.04.2011, 00:17 | Сообщение # 22
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
С запуском разберусь. Исключил VD1, картина таже 1к=1к, 390к=638к.
 
AndrewДата: Суббота, 23.04.2011, 22:11 | Сообщение # 23
Генералиссимус
Группа: Администраторы
Сообщений: 6746
Награды: 16
Репутация: 75
Статус: Offline
значит или 1 к не 1 к или 390 не 390.. не всегда то что написано на деталке соответствует реальности)
Ну не может этот прибор так врать - проверенно!!!
 
bliznecvyДата: Воскресенье, 24.04.2011, 23:48 | Сообщение # 24
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
Уважаемый Andrew, В то, что прибор должен работать как заявлено пока верю. Но у меня следующая картинка_ Старт победил фьюзами, а вот нелинейность пока нет.
33к=36к
36к=39к
75к=90к
100к=120к
220к=300к
390к=660к
Калибровочное 1к проверил на трех приборах. Номиналы деталей проверены.Защитный стаб VD1 отключен.
Генератор добирается до 10-14кГц и МК уходит в полную нирвану,вернуть его обратно можно только рестартом.
Экперимент проводил на двух MEGA8A-PU,+2 кварца+4-22пф что по моим сведениям должо гарантировать работу с кварцем 16мГц. Питание 5.01v. Интрига однако. Умные головы, подкиньте идейку! Спасибо за внимание.
 
AndrewДата: Понедельник, 25.04.2011, 12:14 | Сообщение # 25
Генералиссимус
Группа: Администраторы
Сообщений: 6746
Награды: 16
Репутация: 75
Статус: Offline
Попробуйте заменить С5! Какой тип у вас стоит? У меня стоит керамика желтая термостобильная. Что касается зависания в режиме генератора это скорее глюк компилятора...Решим этот вопрос.
И вопрос, с ATMEGA8A у меня осциллограф не работал...а у вас?
 
bliznecvyДата: Понедельник, 25.04.2011, 22:45 | Сообщение # 26
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
Попробую подбиратьС5 ,осцилограф еще не смотрел, но пару раз заметил отображение импульсов. Сейчас пока молчит.
 
AndrewДата: Понедельник, 25.04.2011, 23:24 | Сообщение # 27
Генералиссимус
Группа: Администраторы
Сообщений: 6746
Награды: 16
Репутация: 75
Статус: Offline
Производители утверждают что ATMEGA8A полная замена ATMEG8-8 ATMEG8-16. Я смотрел регистры одинаковые адреса одинаковые а осциллограф не работает на ATMEGA8A....???
Так вы так и не ответили какого типа у вас С5? Его нужно подбирать не по номиналу а по типу...
 
bliznecvyДата: Вторник, 26.04.2011, 17:37 | Сообщение # 28
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
С5 похож на керамику, точно не скажу, может и пленка. А что, в типе главное, какя характеристика кондера? Проверил частотомер-до22кГц полет нормальный и амплитудку подхватывает даже небольшую. Осцил. молчит. Хотя яуже писал что во время всех экспериментов я наблюдал что-то вроде бегущего меандра. Три раза промыл плату спиртом, продул воздухом.

Добавлено (26.04.2011, 01:08)
---------------------------------------------
На одной Меге заработал осцилограф, различить можно синус и меандр, развертка хорошо рулит, сигнал чуть подробней можно посмотреть.
Главное, что видно изменяющейся во времени сигнал до 22кГц амплитудой от 0 до 5В. Другая Мега стала тупить по всем параметрам, завтра перепрошью. Я шью Flash и EEprom, правильно?

Добавлено (26.04.2011, 01:20)
---------------------------------------------
Цитата:
Фирма ATMEL постоянно производит совершенствование и модификацию своей продукции. Поэтому на смену ряду старых микроконтроллеров пришли новые - с индексом "A". В новой модели снижен ток потребления и теперь диапазон частот, характерный для моделей без индекса и с индексом "L", перекрывается одной моделью "A". Очень незначительно изменены другие электрические параметры.

ATMEGA8A-PU однозначно заменяет следующие микроконтроллеры. Для программатора новый микроконтроллер идентичен старым (имеет ту же сигнатуру и набор "фьюзов"). Ознакомьтесь с документацией производителя о переходе (migration) на новые изделия (на английском языке).

Добавлено (26.04.2011, 17:37)
---------------------------------------------
Эсперементы с С5, калибровками, перепрошивкой результата не дают. Четко выражена нелинейность измерений, как R так и С. Просится калибровка по нескольким значениям, например: R=1k, 10к, 100к, 1мом. У меня две Меги из одной партии, на одной осцилограф работает, на другой нет. Может какой канал подпалил. wacko

Сообщение отредактировал bliznecvy - Вторник, 26.04.2011, 17:40
 
AndrewДата: Вторник, 26.04.2011, 23:13 | Сообщение # 29
Генералиссимус
Группа: Администраторы
Сообщений: 6746
Награды: 16
Репутация: 75
Статус: Offline
Я сам собрал где-то 4 прибора и люди собирали..На нелинейность не кто не жаловался. от 10 ом и до 100 мом...
Конденсаторы везде ставил желтые керамические - термостобильные на упаковке МСС 47nF +-10%.
Калибровали "0"???, а потом 1к? Что показывает прибор если контакты разомкнуты в режиме измерения R?
Каким флюсом пояли?
У меня осцилограф работает только со старыми атмегами с буквой а не работает. Разбираться нет времени...
EEPOM шить не надо.
 
bliznecvyДата: Вторник, 26.04.2011, 23:42 | Сообщение # 30
Генерал-майор
Группа: Пользователи
Сообщений: 295
Награды: 0
Репутация: 10
Статус: Offline
Убедительно, значит у меня точно косяк. Кондеры пробовал самые разные. Флюс обычный спиртоканифоль, да и плату я мыл спиртом и продувал раза 4. Калибровал так,
0 потом 1к. калибруется, выставляется коэфициент, после калиброки показывает последний измереный номинал 1к или 0 если калибровал 0, а нелинейность стабильная,ее можно сдвигать выше, ниже, но она стабильна! может разводка печати вызывает эту нелинейность? Андрей, а какой принцып измерения заложен в Вашем устройстве? Я электронщик, может эта информация меня направит на правильный путь? Функция С5? Честно говоря я пока в тупике. Где собака зарыта? Спасибо за внимание.


Сообщение отредактировал bliznecvy - Вторник, 26.04.2011, 23:55
 
Форум » Измерительная техника » Универсальный измерительный прибор » Универсальный прибор (скриншот осциллографа)
Поиск:


Copyright MyCorp © 2021
Бесплатный конструктор сайтов - uCoz